package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]+(\.5)?)(\+(?1))*$`)
var str = `2.5+1
1+2+2.5
1
1.6
1+2+
0
05.5
1+2+2.5+6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}