$re = '/^([1-9]+(\.5)?)(\+(?1))*$/m';
$str = '2.5+1
1+2+2.5
1
1.6
1+2+
0
05.5
1+2+2.5+6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);