re = /^([1-9]+(\.5)?)(\+(?1))*$/m
str = '2.5+1
1+2+2.5
1
1.6
1+2+
0
05.5
1+2+2.5+6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end