re = /(?:\[|(?!^)\G).*?(\[[^\[\]]*\])/
str = 'This [is] some [d[um]my] text. How to [se[le]ct i[nn]er b]race wi[th[out s]ele[ct]ing th]e outer b[race [in] a tex]t'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end