package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^!(\S+)|)\s+(\S+)`)
var str = `!command param1 param2 param3 paramn param3 param4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}