$re = '/(?:^!(\S+)|)\s+(\S+)/m';
$str = '!command param1 param2 param3 paramn param3 param4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);