re = /(?:^!(\S+)|)\s+(\S+)/m
str = '!command param1 param2 param3 paramn param3 param4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end