import re
regex = re.compile(r"([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})", flags=re.MULTILINE)
test_str = ("00010203\n"
"01010203\n"
"0C0D0E0F")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)