re = /([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})/m
str = '00010203
01010203
0C0D0E0F'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result