import re
regex = re.compile(r"(?<=.)(?=SRS)", flags=re.MULTILINE)
test_str = ("SRS_0081d\n"
"SRS_0079\n"
"SRS_0082SRS_0082a\n"
"SRS_0015SRS_0015cSRS_0015d")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")