re = /(?<=.)(?=SRS)/m
str = 'SRS_0081d
SRS_0079
SRS_0082SRS_0082a
SRS_0015SRS_0015cSRS_0015d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end