use strict;
my $str = '1111-11-34
5551111-11-11
abcd1234-11-11-whatever
abcsgadg1234-22-33666
att_token_2015-09-02
att_token_1234-99-99
att_token_1234
';
my $regex = qr/(?<!\d)\d{4}-\d{2}-\d{2}(?!\d)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}