$re = '/(?<!\d)\d{4}-\d{2}-\d{2}(?!\d)/mi';
$str = '1111-11-34
5551111-11-11
abcd1234-11-11-whatever
abcsgadg1234-22-33666
att_token_2015-09-02
att_token_1234-99-99
att_token_1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);