package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-\s+\[[^:]+:(?<first_name>[^_]+)_(?<last_name>\w+)@[^]]+\] - User authenticated$`)
var str = `2014-10-10 09:58:27 EDT (Framework:INFO) [RID:526] - [sthisisencryptedpassword:firstname_lastname@
serial.mobile.com] - User authenticated`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}