const regex = /-\s+\[[^:]+:(?<first_name>[^_]+)_(?<last_name>\w+)@[^]]+\] - User authenticated$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\s+\\[[^:]+:(?<first_name>[^_]+)_(?<last_name>\\w+)@[^]]+\\] - User authenticated$', '')
const str = `2014-10-10 09:58:27 EDT (Framework:INFO) [RID:526] - [sthisisencryptedpassword:firstname_lastname@
serial.mobile.com] - User authenticated`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}