re = /-\s+\[[^:]+:(?<first_name>[^_]+)_(?<last_name>\w+)@[^]]+\] - User authenticated$/
str = '2014-10-10 09:58:27 EDT (Framework:INFO) [RID:526] - [sthisisencryptedpassword:firstname_lastname@
serial.mobile.com] - User authenticated'
# Print the match result
str.match(re) do |match|
puts match.to_s
end