#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^\n\r:]*)(:[ \t])[ \t]*([^\n\r]*)"
Local $sString = "NetRange: 2001:4860:: - 2001:4860:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF" & @CRLF & _
"CIDR: 2001:4860::/32" & @CRLF & _
"NetName: GOOGLE-IPV6" & @CRLF & _
"NetHandle: NET6-2001-4860-1" & @CRLF & _
"Parent: ARIN-004 (NET6-2001-4800-0)" & @CRLF & _
"NetType: Direct Allocation" & @CRLF & _
"OriginAS: AS15169" & @CRLF & _
"Organization: Google LLC (GOGL)" & @CRLF & _
"RegDate: 2005-03-14" & @CRLF & _
"Updated: 2012-02-24" & @CRLF & _
"Ref: https://rdap.arin.net/registry/ip/2001:4860::" & @CRLF & _
"" & @CRLF & _
"OrgName: Google LLC" & @CRLF & _
"OrgId: GOGL" & @CRLF & _
"Address: 1600 Amphitheatre Parkway" & @CRLF & _
"City: Mountain View" & @CRLF & _
"StateProv: CA" & @CRLF & _
"PostalCode: 94043" & @CRLF & _
"Country: US" & @CRLF & _
"RegDate: 2000-03-30" & @CRLF & _
"Updated: 2019-10-31" & @CRLF & _
"Comment: Please note that the recommended way to file abuse complaints are located in the following links. " & @CRLF & _
"Comment: " & @CRLF & _
"Comment: To report abuse and illegal activity: https://www.google.com/contact/" & @CRLF & _
"Comment: " & @CRLF & _
"Comment: For legal requests: http://support.google.com/legal " & @CRLF & _
"Comment: " & @CRLF & _
"Comment: Regards, " & @CRLF & _
"Comment: The Google Team" & @CRLF & _
"Ref: https://rdap.arin.net/registry/entity/GOGL" & @CRLF & _
"" & @CRLF & _
"OrgTechHandle: ZG39-ARIN" & @CRLF & _
"OrgTechName: Google LLC" & @CRLF & _
"OrgTechPhone: +1-650-253-0000 " & @CRLF & _
"OrgTechEmail: arin-contact@google.com" & @CRLF & _
"OrgTechRef: https://rdap.arin.net/registry/entity/ZG39-ARIN" & @CRLF & _
"OrgAbuseHandle: ABUSE5250-ARIN" & @CRLF & _
"OrgAbuseName: Abuse" & @CRLF & _
"OrgAbusePhone: +1-650-253-0000 " & @CRLF & _
"OrgAbuseEmail: network-abuse@google.com" & @CRLF & _
"OrgAbuseRef: https://rdap.arin.net/registry/entity/ABUSE5250-ARIN" & @CRLF & _
"RNOCHandle: ZG39-ARIN" & @CRLF & _
"RNOCName: Google LLC" & @CRLF & _
"RNOCPhone: +1-650-253-0000 " & @CRLF & _
"RNOCEmail: arin-contact@google.com" & @CRLF & _
"RNOCRef: https://rdap.arin.net/registry/entity/ZG39-ARIN" & @CRLF & _
"RTechHandle: ZG39-ARIN" & @CRLF & _
"RTechName: Google LLC" & @CRLF & _
"RTechPhone: +1-650-253-0000 " & @CRLF & _
"RTechEmail: arin-contact@google.com" & @CRLF & _
"RTechRef: https://rdap.arin.net/registry/entity/ZG39-ARIN" & @CRLF & _
"RAbuseHandle: ZG39-ARIN" & @CRLF & _
"RAbuseName: Google LLC" & @CRLF & _
"RAbusePhone: +1-650-253-0000 " & @CRLF & _
"RAbuseEmail: arin-contact@google.com" & @CRLF & _
"RAbuseRef: https://rdap.arin.net/registry/entity/ZG39-ARIN"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")