import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\n\\r:]*)(:[ \\t])[ \\t]*([^\\n\\r]*)";
final String string = "NetRange: 2001:4860:: - 2001:4860:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF\n"
+ "CIDR: 2001:4860::/32\n"
+ "NetName: GOOGLE-IPV6\n"
+ "NetHandle: NET6-2001-4860-1\n"
+ "Parent: ARIN-004 (NET6-2001-4800-0)\n"
+ "NetType: Direct Allocation\n"
+ "OriginAS: AS15169\n"
+ "Organization: Google LLC (GOGL)\n"
+ "RegDate: 2005-03-14\n"
+ "Updated: 2012-02-24\n"
+ "Ref: https://rdap.arin.net/registry/ip/2001:4860::\n\n"
+ "OrgName: Google LLC\n"
+ "OrgId: GOGL\n"
+ "Address: 1600 Amphitheatre Parkway\n"
+ "City: Mountain View\n"
+ "StateProv: CA\n"
+ "PostalCode: 94043\n"
+ "Country: US\n"
+ "RegDate: 2000-03-30\n"
+ "Updated: 2019-10-31\n"
+ "Comment: Please note that the recommended way to file abuse complaints are located in the following links. \n"
+ "Comment: \n"
+ "Comment: To report abuse and illegal activity: https://www.google.com/contact/\n"
+ "Comment: \n"
+ "Comment: For legal requests: http://support.google.com/legal \n"
+ "Comment: \n"
+ "Comment: Regards, \n"
+ "Comment: The Google Team\n"
+ "Ref: https://rdap.arin.net/registry/entity/GOGL\n\n"
+ "OrgTechHandle: ZG39-ARIN\n"
+ "OrgTechName: Google LLC\n"
+ "OrgTechPhone: +1-650-253-0000 \n"
+ "OrgTechEmail: arin-contact@google.com\n"
+ "OrgTechRef: https://rdap.arin.net/registry/entity/ZG39-ARIN\n"
+ "OrgAbuseHandle: ABUSE5250-ARIN\n"
+ "OrgAbuseName: Abuse\n"
+ "OrgAbusePhone: +1-650-253-0000 \n"
+ "OrgAbuseEmail: network-abuse@google.com\n"
+ "OrgAbuseRef: https://rdap.arin.net/registry/entity/ABUSE5250-ARIN\n"
+ "RNOCHandle: ZG39-ARIN\n"
+ "RNOCName: Google LLC\n"
+ "RNOCPhone: +1-650-253-0000 \n"
+ "RNOCEmail: arin-contact@google.com\n"
+ "RNOCRef: https://rdap.arin.net/registry/entity/ZG39-ARIN\n"
+ "RTechHandle: ZG39-ARIN\n"
+ "RTechName: Google LLC\n"
+ "RTechPhone: +1-650-253-0000 \n"
+ "RTechEmail: arin-contact@google.com\n"
+ "RTechRef: https://rdap.arin.net/registry/entity/ZG39-ARIN\n"
+ "RAbuseHandle: ZG39-ARIN\n"
+ "RAbuseName: Google LLC\n"
+ "RAbusePhone: +1-650-253-0000 \n"
+ "RAbuseEmail: arin-contact@google.com\n"
+ "RAbuseRef: https://rdap.arin.net/registry/entity/ZG39-ARIN";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}