const regex = new RegExp('^([A-Za-z0-9]*[- ])*', '')
const str = `Walt Disney World Quest - Magical Racing Tour (E) (M3) [C][!]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}