re = /^([A-Za-z0-9]*[- ])*/
str = 'Walt Disney World Quest - Magical Racing Tour (E) (M3) [C][!]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end