$re = '/^([A-Za-z0-9]*[- ])*/';
$str = 'Walt Disney World Quest - Magical Racing Tour (E) (M3) [C][!]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);