$re = '/<b>(?:(?!<\/b>).)*<b>/m';
$str = 'This is some <b>correct</b> formatting
This is some <b>incorrect<b> formatting';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);