#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)\W+(\d{4})(?=[\W ]+?(\d{3,4})p)"
Local $sString = "Jumanji.1995-720p.YIFY.mp4" & @CRLF & _
"Silver.Linings.Playbook.2012.1080p.x264.YIFY.mp4" & @CRLF & _
"American Hustle (2013) 1080p BrRip x264 - YIFY.mp4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")