import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\W+(\\d{4})(?=[\\W ]+?(\\d{3,4})p)";
final String string = "Jumanji.1995-720p.YIFY.mp4\n"
+ "Silver.Linings.Playbook.2012.1080p.x264.YIFY.mp4\n"
+ "American Hustle (2013) 1080p BrRip x264 - YIFY.mp4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}