const regex = /^(.*?)\W+(\d{4})(?=[\W ]+?(\d{3,4})p)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)\\W+(\\d{4})(?=[\\W ]+?(\\d{3,4})p)', 'gm')
const str = `Jumanji.1995-720p.YIFY.mp4
Silver.Linings.Playbook.2012.1080p.x264.YIFY.mp4
American Hustle (2013) 1080p BrRip x264 - YIFY.mp4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}