package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*?\binput\b.*? (\S+),`)
var str = `input read_enable,
input [WIDTH-1 : 0] write_data,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}