re = /.*?\binput\b.*? (\S+),/
str = 'input read_enable,
input [WIDTH-1 : 0] write_data,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end