$re = '/.*?\binput\b.*? (\S+),/';
$str = 'input read_enable,
input [WIDTH-1 : 0] write_data,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);