#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) (\h*\( # capture groups, open brackets" & @CRLF & _
" [^)]*? # match everything BUT a closing bracket lazily" & @CRLF & _
" (?i:picture|see|lorem) # up to one of the words, case insensitive" & @CRLF & _
" [^)]*? # same construct as above" & @CRLF & _
" \)) # up to a closing bracket"
Local $sString = "Hello world (see below)." & @CRLF & _
"Lorem ipsum (there is a picture here) world!" & @CRLF & _
"Attack on titan (is lorem) great but (should not be removed)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")