package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` (\h*\( # capture groups, open brackets
[^)]*? # match everything BUT a closing bracket lazily
(?i:picture|see|lorem) # up to one of the words, case insensitive
[^)]*? # same construct as above
\)) # up to a closing bracket`)
var str = `Hello world (see below).
Lorem ipsum (there is a picture here) world!
Attack on titan (is lorem) great but (should not be removed).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}