re = / (\h*\( # capture groups, open brackets
[^)]*? # match everything BUT a closing bracket lazily
(?i:picture|see|lorem) # up to one of the words, case insensitive
[^)]*? # same construct as above
\)) # up to a closing bracket/x
str = 'Hello world (see below).
Lorem ipsum (there is a picture here) world!
Attack on titan (is lorem) great but (should not be removed).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end