const regex = /\b(\w{3,})ay\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w{3,})ay\\b', 'gi')
const str = `I work every day except monday, tuesday, wednesday and thursday`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);