$re = '/\b(\w{3,})ay\b/i';
$str = 'I work every day except monday, tuesday, wednesday and thursday';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;