re = /\b(\w{3,})ay\b/i
str = 'I work every day except monday, tuesday, wednesday and thursday'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result