import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+)?(((((\\d+)|(\\(\\d+\\))|(\\(\\d+\\s(\\d)\\)))(\\s|-|\\d+))+)|((\\d+)|(\\(\\d+\\))$)+)+\\d$";
final String string = "+44 161 999 8888";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}