re = /^(\+)?(((((\d+)|(\(\d+\))|(\(\d+\s(\d)\)))(\s|-|\d+))+)|((\d+)|(\(\d+\))$)+)+\d$/
str = '+44 161 999 8888'
# Print the match result
str.match(re) do |match|
puts match.to_s
end