const regex = /^(\+)?(((((\d+)|(\(\d+\))|(\(\d+\s(\d)\)))(\s|-|\d+))+)|((\d+)|(\(\d+\))$)+)+\d$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+)?(((((\\d+)|(\\(\\d+\\))|(\\(\\d+\\s(\\d)\\)))(\\s|-|\\d+))+)|((\\d+)|(\\(\\d+\\))$)+)+\\d$', '')
const str = `+44 161 999 8888`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}