#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d(\s){1,10}(.)*\s{1,}\$\d\.[0-9]{2}"
Local $sString = " Tim Hortons" & @CRLF & _
" Alwasy Fresh" & @CRLF & _
"" & @CRLF & _
"1 Brek Wrap Combo /A ($0.76)" & @CRLF & _
"1 Bacon-wrap $3.79" & @CRLF & _
"1 Grilled $0.00" & @CRLF & _
"1 5 Pieces Bacon-wrap $0.00" & @CRLF & _
"1 Orange $1.40" & @CRLF & _
"1 Deposit $0.10" & @CRLF & _
"Subtotal: $55.84" & @CRLF & _
"GST: $0.29" & @CRLF & _
"Debit: $55.84" & @CRLF & _
"Take out" & @CRLF & _
"" & @CRLF & _
" Thanks for stopping by!!" & @CRLF & _
" Tell us how we did"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")