# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d(\s){1,10}(.)*\s{1,}\$\d\.[0-9]{2}"
test_str = (" Tim Hortons\n"
" Alwasy Fresh\n\n"
"1 Brek Wrap Combo /A ($0.76)\n"
"1 Bacon-wrap $3.79\n"
"1 Grilled $0.00\n"
"1 5 Pieces Bacon-wrap $0.00\n"
"1 Orange $1.40\n"
"1 Deposit $0.10\n"
"Subtotal: $55.84\n"
"GST: $0.29\n"
"Debit: $55.84\n"
"Take out\n\n"
" Thanks for stopping by!!\n"
" Tell us how we did")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.