re = /\d(\s){1,10}(.)*\s{1,}\$\d\.[0-9]{2}/m
str = ' Tim Hortons
Alwasy Fresh
1 Brek Wrap Combo /A ($0.76)
1 Bacon-wrap $3.79
1 Grilled $0.00
1 5 Pieces Bacon-wrap $0.00
1 Orange $1.40
1 Deposit $0.10
Subtotal: $55.84
GST: $0.29
Debit: $55.84
Take out
Thanks for stopping by!!
Tell us how we did'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end