import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(\\d+)\\s+(.*\\S)\\s+(\\(?)\\$([0-9.]+)\\)?\\s*$";
final String string = " Tim Hortons\n"
+ " Alwasy Fresh\n\n"
+ "1 Brek Wrap Combo /A ($0.76)\n"
+ "1 Bacon-wrap $3.79\n"
+ "1 Grilled $0.00\n"
+ "1 5 Pieces Bacon-wrap $0.00\n"
+ "1 Orange $1.40\n"
+ "1 Deposit $0.10\n"
+ "Subtotal: $55.84\n"
+ "GST: $0.29\n"
+ "Debit: $55.84\n"
+ "Take out\n\n"
+ " Thanks for stopping by!!\n"
+ " Tell us how we did";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}