const regex = /^\s*(\d+)\s+(.*\S)\s+(\(?)\$([0-9.]+)\)?\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(\\d+)\\s+(.*\\S)\\s+(\\(?)\\$([0-9.]+)\\)?\\s*$', 'gm')
const str = ` Tim Hortons
Alwasy Fresh
1 Brek Wrap Combo /A (\$0.76)
1 Bacon-wrap \$3.79
1 Grilled \$0.00
1 5 Pieces Bacon-wrap \$0.00
1 Orange \$1.40
1 Deposit \$0.10
Subtotal: \$55.84
GST: \$0.29
Debit: \$55.84
Take out
Thanks for stopping by!!
Tell us how we did`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}