import re
regex = re.compile(r"^\s*(\d+)\s+(.*\S)\s+(\(?)\$([0-9.]+)\)?\s*$", flags=re.MULTILINE)
test_str = (" Tim Hortons\n"
" Alwasy Fresh\n\n"
"1 Brek Wrap Combo /A ($0.76)\n"
"1 Bacon-wrap $3.79\n"
"1 Grilled $0.00\n"
"1 5 Pieces Bacon-wrap $0.00\n"
"1 Orange $1.40\n"
"1 Deposit $0.10\n"
"Subtotal: $55.84\n"
"GST: $0.29\n"
"Debit: $55.84\n"
"Take out\n\n"
" Thanks for stopping by!!\n"
" Tell us how we did")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")