using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?![0-9]+\$?)";
string input = @"breakfast 10,000$, buy new phone 1k , paying bills 1500$ => breakfast 10$, buy new phone 1k, paying bills 1500$";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}