re = /,(?![0-9]+\$?)/
str = 'breakfast 10,000$, buy new phone 1k , paying bills 1500$ => breakfast 10$, buy new phone 1k, paying bills 1500$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end