$re = '/,(?![0-9]+\$?)/';
$str = 'breakfast 10,000$, buy new phone 1k , paying bills 1500$ => breakfast 10$, buy new phone 1k, paying bills 1500$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);