const regex = /(.+\/)[^.]+\.([^.]+\.ha)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+\\\/)[^.]+\\.([^.]+\\.ha)$', 'gm')
const str = `/myhome/ishere/where/are.you.ha`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);