$re = '/(.+\/)[^.]+\.([^.]+\.ha)$/m';
$str = '/myhome/ishere/where/are.you.ha';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;