import re
regex = re.compile(r"(.+\/)[^.]+\.([^.]+\.ha)$", flags=re.MULTILINE)
test_str = "/myhome/ishere/where/are.you.ha"
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)