#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?!KM)([A-Z]{2})\h(\d{3})"
Local $sString = "BA 093, RJ 342, ES 324, KM 324, KM 123"
Local $sSubst = "$1-$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)